Calling all SLPs and teachers to update the iOS system on their iPads & iPods

(This post originally appeared on GeekSLP)

The iPad, iPhone and iPod touch run an operational system called the iOS system. This is the system that allows you to run apps and perform all functions on your device. It comes pre-installed on your devices when you purchase it from the Apple store.

It is very important that you keep your iOS system up to date in order to have apps run smoothly and also take advantage of the enhancements  and the possible bug fixes provided by Apple.

Updating your iOS system is FREE

While most apps will work on older versions of the iOS system, keeping an up-to date update will guarantee you best performances.

In fact, some apps also do not work on older iOS versions (e.g 3.1); therefore you will not be allowed to purchase the app from the app store. First let’s learn how to identify which version of the iOS system you are running on your device.

1. Identifying the iOS system on your device:

1st. Go to the setting area on your device and click on “General”:

2nd. Under the “General” menu, click on ” About”:

3rd. Under the “About” menu you will see the information you are looking for under the “Version“.

On this example you can see I have the Version 4.3.2 of the iOS system; which is the most most up to date version as of 4/23/2011.

2. Understand app’s iOS requirements

Now that you know how to identify which version you have, now let’s learn about the fact that some apps do not support older version of the iOS system.

When you are purchasing an app from the app store you will notice that the app has several requirements, one of them is compatibility with iOS systems. Take fore example the number one, best selling educational application: Star Walk for iPad ; it requires that you have the iOS 3.2 in order to run this app. See image below:

Notice that the app requires that you have iOS 3.2 or later; if you have anything older the app will not install. Another example is an AAC app called Expressive:

As you can see, Expressive requires that users have the version 3.1.4 or older in order to run the app on the devices.

Now that you know how to identify your iOS system, and understand that some apps will not run on older versions of the iOS system; you will need to know how to update it. This is the easy part of the whole story.

3. Updating your iOS system

You will need to connect your device ( iPhone, iPod or iPad) to your computer to update it.

1. Plug your device

2. Open iTunes

3. Select your device and make sure you are under the ” Summary” section.

4. Click on “Check for Update”.

You are all done!

I hope it helps… Now go update your device

Barbara Fernandes is a trilingual Speech- Language pathologist, a geek  and an app developer. She is the founder and CEO of Smarty Ears Apps , a company that creates apps for speech therapy. Barbara is also the face behind GeekSLP TV, a blog and video podcast focusing on the use of technology in speech therapy. Barbara has also been a practicing speech therapist both in Brazil and in the United States. Barbara has created over 21 applications for the mobile devices for speech therapists.